Follow

What are the minimum system requirements for using SnappyTV?

Operating Systems

Windows XP or Later
Mac OSX  10.6 or Later

Browser Versions

  • Firefox - Version 10 or Later
  • Safari - Version 5 or Later
  • Chrome - Version 12 or Later
  • Internet Explorer - IE8 or Later
  • Flash Player - 11 or Later. 

0 Comments

Please sign in to leave a comment.